Intel Turbo Boost Max Technology app

This is the general discussion area. Everyone is welcome, but you must register to post.

Moderator: RLG MGMT Team

Post Reply
Posts: 4583
Joined: 11 May 2005, 14:50

Intel Turbo Boost Max Technology app

Post by Hammer »

I recently added a CPU that uses this technology (not all Intel CPU's do, so do not worry if you do not have this issue) and Win10 installed the utility automatically (via windows update). It is a useful utility as it can assign demanding apps to the core(s) that boost the highest under load (yes, some CPU's have a core or two that will boost higher than the others). The problem is that the utility was not configured properly upon install (by windows update). If you have this utility and it pops up and stays open on your desktop instead of minimizing like it should (or did in the past) here are the steps t correct this.

1. Exit app from taskbar or kill it from task manager.

2. Open up task scheduler and stop the task by rightclicking and pressing "end" ( ... ws-10.html )

3. Select the intel turbo boost task and click the "stop/end" button in the right lower frame.

4. Double click the intel turbo boost task (in the middle top window)

5. Click on the hidden check box in the lower left of the window and then go to Actions tab -> select the "Start a program" and click "Edit"

5. In the add arguments field make sure there is a SPACE between -d (deamonise) and -q (quiet) so : -d -q (instead of the faulty -d-q)

6. Add quotation marks to the start and end of the program/script field like so -> "C:\Program Files (x86)\Intel Corporation\Intel(R) Turbo Boost Max Technology 3.0\ITBM.EXE"

7. Press OK until you exit back to the main task scheduler window.

8. Manually run the task by clicking the "Play" button (you must still have the task selected) and see if it works.

To configure it right click on it in the system tray, go to the UI, Make sure it is set to enabled, foreground app has priority (unless you think you might want a background app to have priority - the app assigns the most demanding app to the diverse core if this is unchecked - most of us will want the game we are playing in the foreground to have priority). You can click on the menu in the upper right and go to settings for more advanced settings, the help for the app is pretty good. Hopefully this works - it seems hit and miss sometimes.
Post Reply